Light-electric.com

IT Журнал
4 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Excel если иначе

Функция ЕСЛИ (IF) в Excel — правила использования, примеры

Функция ЕСЛИ() применяется для выборки значения (-ий) по заданному условию (-ий). Аргументы функции:

Аргумент Лог_выражение применяется для записи непосредственно условия поиска. Возвращает логические значения «истина» или «ложь». Для формирования условия, значения можно брать как из ячеек, так и записывать непосредственно в формуле.

Два остальных аргумента — для вывода значения, если первый аргумент вывел «истину» и второй если вывел «ложь».

Например, требуется сравнить два значения и вывести в ячейке большее значение. Синтаксис формулы такой:

=ЕСЛИ(B2>C2;B2;C2) – читается так, если значение B2 больше C2 выводим B2, иначе C2:

Тоже самое можно сделать для разных форматов, например, для текста:

В этом примере я проверяю значение ячейки B4 и если там слово «яблоко» (написано непосредственно в строке условия, в двойных кавычках), то показать слово «фрукт». Аргументы если «истина» и, если «ложь» являются не обязательными, в случае их отсутствия, при выполнения условия будет выводиться слово «истина» или слово «ложь».

В моем примере, если написать в B4 любое другое слово программа скажет:

Примеры функции ЕСЛИ(IF) с несколькими условиями.

Часто бывает, что необходимо использовать два и более условия. Для решения этой задачи мы будем вкладывать функцию в функцию.

Возьмем предыдущий пример, и напишем дополнительное условие для слова груши:

Читается так: если B4 равно «яблоко», то выводим слово «фрукт», иначе (выполняем следующую функцию ЕСЛИ) если B4 равно «груша», то выводим слово «фрукт», иначе выводим «не фрукт».

Таких вложений может быть до 64!

Функция ЕСЛИ() выполняет условия строго по порядку и завершает свою работу, если условие было выполнено.

Это очень важное замечание в использовании формулы его необходимо учитывать. Приведу пример поломанной логики:

У нас есть таблица фруктов с количеством и себестоимостью, а нам надо определить исходя из себестоимости, нашу наценку для получения итоговой цены. Также у нас есть таблица наценок, которые зависят от себестоимости фрукта:

Применяем такую формулу:

и протягиваем ее:

Получаем 10% для всех значений. Формула начинается работу с первого аргумента – он возвращает истину, и формула завершает свою работу.

Здесь спасти положение может только добавление в функцию ЕСЛИ() функцию И(), для проверки в каком диапазоне находится себестоимость, и какую наценку надо выводить:

Примеры использования функции ЕСЛИ()

Заменим в предыдущем примере столбец наценка на столбец цена и будем выводить сразу итоговую цену. Формула примет следующий вид:

Главное не запутаться в скобках . Протягиваем формулу:

На этом все, если у вас есть вопросы оставляйте в комментариях.

Функция ЕСЛИ() в EXCEL

Функция ЕСЛИ() относится к наиболее часто используемым функциям.

Синтаксис функции

ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. =ЕСЛИ(A1>=100;»Бюджет превышен»;»ОК!») Т.е. если в ячейке A1 содержится значение большее или равное 100, то формула вернет ОК!, а если нет, то Бюджет превышен .

В качестве аргументов функции, могут участвовать формулы, например: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше, то по столбцу С .

Вложенные ЕСЛИ

В EXCEL 2007 в качестве значений аргументов значение_если_истина и значение_если_ложь можно для построения более сложных проверок использовать до 64 вложенных друг в друга функций ЕСЛИ() . =ЕСЛИ(A1>=100;»Бюджет превышен»;ЕСЛИ(A1>=90;»Крупный проект»;ЕСЛИ(A1>=50;»Средний проект»;»Малый проект «)))

Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы:

Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

Если требуется вывести разный текст в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0, то можно записать следующую формулу:

или, если требуется вместо текстовых значений вывести формулы, можно использовать ссылки на диапазон ячеек (содержащих формулы)

=ПРОСМОТР(A24;<-1E+307;0;1E-307>;A27:A29) (см. файл примера )

Опущен третий аргумент [значение_если_ложь]

Третий аргумент функции не обязателен, если его опустить, то функция вернет значение ЛОЖЬ (если условие не выполнено). =ЕСЛИ(A1>100;»Бюджет превышен») Если в ячейке A1 содержится значение 1, то вышеуказанная формула вернет значение ЛОЖЬ.

Вместо ИСТИНА или ЛОЖЬ в первом аргументе введено число

Т.к. значение ЛОЖЬ эквивалентно 0, то формулы =ЕСЛИ(0;»Бюджет превышен»;»ОК!») или (если в ячейке A1 содержится значение 0) =ЕСЛИ(A1;»Бюджет превышен»;»ОК!») вернут ОК!

Если в ячейке A1 находится любое другое число кроме 0, то формула вернет Бюджет превышен . Такой подход удобен, когда проверяется равенство значения нулю.

Связь функции ЕСЛИ() с другими функциями использующие условия

EXCEL содержит также другие функции, которые можно применять для анализа данных с использованием условий. Например, для подсчета количества вхождений чисел в диапазоне ячеек используется функция СЧЁТЕСЛИ() , а для сложения значений, удовлетворяющих определенным условиям, используется функция СУММЕСЛИ() .

Функция ЕСЛИ() , как альтернативный вариант, может быть также использована для подсчета и сложения значений с использованием условий. Ниже приведены иллюстрирующие примеры.

Пусть данные находятся в диапазоне A6:A11 (см. файл примера)

Подсчитаем сумму значений, которые больше 10 с помощью функции СУММЕСЛИ() , записав =СУММЕСЛИ(A6:A11;»>10″) . Аналогичный результат (23) можно получить с помощью формулы массива =СУММ(ЕСЛИ(A6:A11>10;A6:A11)) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

Читать еще:  Как убрать пароль с книги excel

Теперь подсчитаем количество вхождений чисел больше 10 в диапазоне ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;»>10″) . Аналогичный результат (2) можно получить с помощью формулы массива =СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

Теперь, когда принцип понятен, с помощью функции ЕСЛИ() можно конструировать и другие формулы с условиями. Например, нахождение минимального значения среди чисел больше 10: =МИН(ЕСЛИ(A6:A11>10;A6:A11))

ITGuides.ru

Вопросы и ответы в сфере it технологий и настройке ПК

Примеры использования функции проверки условия (ЕСЛИ) в Excel

Функция ЕСЛИ относится к логическим функциям Microsoft Excel и является одной из наиболее часто используемых в работе. С помощью этого оператора можно выполнять различные задачи, когда необходимо сравнить какие-то данные и выдать результат. Функция ЕСЛИ в Excel дает возможность использовать в работе ветвящиеся алгоритмы, строить дерево решений и т.д.

Видео по использованию функции ЕСЛИ в Excel

Примеры использования оператора ЕСЛИ

Функция ЕСЛИ выглядит следующим образом:

=ЕСЛИ (выражение; истина; ложь).

А теперь немного подробнее:

  1. Выражение — это логическое выражение, которое может быть числом или фразой. Например «10» — это логическое выражение, «без НДС» — тоже логическое выражение. Это единственный параметр, который заполняется в обязательном порядке.
  2. Истина — значение, которое будет выдано в качестве результата, если выражение окажется истинным.
  3. Ложь — значение, которое будет выдано, если выражение будет ложным.

Простейший пример реализации функции ЕСЛИ в Excel — проверяем равенство значений двух ячеек

К примеру, можно ввести в поле C1 цифру 8, а в поле D1 написать так: =ЕСЛИ(C1 );

  • меньше ( =);
  • меньше или равно ( ).
  • Примеры функций И, ИЛИ

    Также при использовании в Экселе функции ЕСЛИ есть возможность соединить ее с простыми операторами сравнения (вроде И, ИЛИ). Например, можно написать такое условие: =ЕСЛИ(И(A1 3); «проходит», «не проходит»). Получается следующее условие: если оценка студента меньше или равна 5 и больше 3, то будет показан комментарий «проходит», в противном случае — «не проходит» (проходят только те студенты, у которых в оценках стоят четверки и пятерки).

    Более сложный пример использования функции ЕСЛИ — с использованием условий И либо ИЛИ

    Следующее условие с примером оператора ИЛИ: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). Получается, что если число в ячейке А1 равняется 5 или 10, то программа выдаст 100, в противном случае — 0.

    Кроме того, можно применять эти простые операторы и для решения более сложных задач. Например, в базе данных необходимо отобрать должников, которые должны более 10 тысяч рублей и уже не платили более 6 месяцев. Если программа найдет такого человека, то пусть выдаст критерий «проблемный заемщик».

    Допустим, в ячейке A1 находится информация о сроке задолженности (в месяцах), а в поле B1 — сумма задолженности. Тогда формула будет выглядеть следующим образом: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный заемщик»; «»). Если будет найден человек, который подходит под указанное условие, то программа напишет напротив его фамилии комментарий «проблемный заемщик», в противном случае ячейка останется пустой.

    Если один из параметров считается критическим, тогда можно составить формулу так: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Если программа найдет совпадения хотя бы по одному параметру (либо срок, либо сумма задолженности), то пользователь увидит сообщение о том, что ситуация критическая. Разница с предыдущей формулой в том, что в первом случае сообщение «проблемный заемщик» выдавалось только тогда, когда выполнялись оба условия.

    Другие примеры использования оператора ЕСЛИ

    Функцию ЕСЛИ можно использовать для обхода встроенных ошибок деления на ноль, и еще в ряде случаев

    Очень часто в Экселе возникает такая ошибка, как «ДЕЛ/0», т.е. деление на 0. Как правило, она появляется в техслучаях, когда копируется формула «A/B», а число B в некоторых ячейках равняется нулю. Этого можно избежать, если использовать оператор ЕСЛИ. Для этого необходимо написать так: =ЕСЛИ(B1=0; 0; A1/B1). Получается, что если в ячейке B1 будет ноль, то Excel сразу же выдаст ноль, в противном случае программа поделит A1 на B1 и выдаст результат.

    Еще одна ситуация, которая довольно часто встречается на практике, расчет скидки в зависимости от общей суммы покупки. Для этого понадобится примерно такая матрица:

    • до 1000 — 0%;
    • от 1001 до 3000 — 3%;
    • от 3001 до 5000 — 5%;
    • свыше 5001 — 7%.

    К примеру, в Excel есть условная база данных клиентов и информация о том, сколько они потратили на покупки. Задача состоит в том, чтобы рассчитать для них скидку. Для этого можно написать так: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..). Суть ясна: проверяется общая сумма покупок, и когда она, к примеру, больше 5001 рублей, то умножается на 93% стоимости товара (ячейка B1*0,93), когда больше 3001 рублей, то умножается на 95% стоимости товара и т.д. Такую формулу легко можно использовать и на практике: уровень объема продаж и уровень скидок устанавливается на ваше усмотрение.

    Читать еще:  Значение по модулю в excel

    Таким образом, применять функцию ЕСЛИ можно практически в любой ситуации, функциональность Microsoft Excel это позволяет. Главное — правильно составить формулу, чтобы результат не оказался ошибочным.

    Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

    Блог Евгения Крыжановского

    Я научу вас ремонтировать свой компьютер!

    Excel: «Если» (формула). В Excel функция «Если»

    В статье речь пойдет о функции табличного редактора Excel «Если». Она связана с логическими возможностями приложения. Данную функцию можно отнести к наиболее распространенной, которая зачастую используется во время работы.

    Ключевые возможности

    В программе Excel формула «Если» позволяет различного рода задачи, которые требуют сравнить определенные значения и получить результат. Такое решение дает возможность использовать ветвящиеся алгоритмы, создавать дерево решений.

    Примеры применения

    Функция имеет вид: =ЕСЛИ (задача; истина; ложь). Первой составной частью является логическое выражение. Оно способно выступать в виде фразы или числа. Например, «10» или «без НДС». Такой параметр обязательно следует заполнить. Истина представляет собой значение, отображающееся в качестве результата, если выражение верно. Ложь представляет собой данные, которые будут выданы, когда задача неверна.

    Равенство параметров двух ячеек

    Чтобы лучше понять возможности функции «Если» в Excel, необходимо привести примеры. Поэтому дальше стоит приступить к их рассмотрению. Нужно ввести в клетку C1 значение 8. После этого в поле по адресу D1 необходимо вписать формулу вида: =ЕСЛИ(C1 , =, >, =, 3); «проходит», «нет»).

    Если рассмотреть более сложный пример, понадобится использовать «ИЛИ» либо «И». Таким образом, можно ознакомиться с применением формулы в Excel, если существует несколько условий в задании. Например: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). В данном случае можно сделать вывод, когда значение в клетке А1 равно 5 или 10, программа отображает результат 100. В противном случае он составляет 0. Существует возможность применить эти операторы, чтобы найти решение более сложным задачам.

    Например, в базе требуется вычислить должников, которым требуется заплатить более 10000 рублей. Можно задать условие, что заем не погашался более полугода, то есть шести месяцев. Благодаря функции табличного редактора Excel «Если» позволяется в автоматическом режиме получить около соответствующих имен отметку «проблемный клиент». Допустим, в клетке A1 размещены данные, которые указывают на срок задолженности (месяцы). Поле B1 содержит сумму.

    В данном случае формула представлена в следующем виде: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный клиент»; «»). Таким образом, если выявлен человек, соответствующий указанным условиям, программа отображает напротив его имени соответствующий комментарий. Для других участников списка эта клетка останется пустой.

    Также можно ознакомиться с примером, когда ситуация является критической. Необходимо ввести соответствующий комментарий. Как результат, формула получится следующей: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Однако если программа определяет совпадения по одному из параметров как минимум, отображается соответствующее примечание.

    Сложные задачи

    Функция Excel «Если» применяется для того, чтобы избежать встроенных ошибок при делении на ноль. Кроме того, она используется и в некоторых других ситуациях. Первый случай обозначается, как «ДЕЛ/0». Его можно встретить достаточно часто. Обычно это происходит тогда, когда формула «A/B» требует копирования. В это же время показатель B в отдельных ячейках составляет 0. Чтобы избежать подобной ситуации, стоит использовать возможности рассматриваемого оператора. Таким образом, требуемая формула имеет следующий вид: =ЕСЛИ(B1=0; 0; A1/B1). Итак, если клетка B1 заполнена значением «ноль», редактор отобразит «0». В противном случае программа поделит показатель A1 на данные B1 и выдаст требуемый результат.

    Скидка

    Как показывает практика, зачастую возникают ситуации, которые рассматриваются далее. Потребуется рассчитать скидки, учитывая общую сумму средств, затраченных на покупку конкретного товара. Матрица, которая используется, выглядит следующим образом: менее 1000 — 0%; 1001-3000 — 3%; 3001-5000 — 5%; более 5001 — 7%. Можно ознакомиться с ситуацией, когда в Excel имеется база данных посетителей и сведения о сумме, потраченной на покупку. Далее следует рассчитать скидку для каждого клиента. Для этого понадобится применить следующее выражение: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..).

    Система выполняет проверку общей суммы покупок. Если она превышает значение в 5001 рублей, выполняется умножение на 93 процента цены товара. Если превышена отметка в 3001 единиц, происходит аналогичное действие, однако уже учитывается 95%.

    Запись опубликована 17.09.2015 автором katrinas11 в рубрике Программы. Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

    Функция «ЕСЛИ» в Excel с примерами

    Офисный пакет приложений помогает выполнять множество задач в разных областях. Так, MS Excel, являющийся табличным процессором, способен решить разнообразные задачи. Достаточно ввести функцию, и вот он – результат. Как правило, это приложение используют в бухгалтерском учете, но и не только. А во всем многообразии функция «ЕСЛИ» занимает далеко не последнее место.

    Общие сведения об электронной таблице MS Excel

    Табличный процессор предназначен для организации расчетов, построения графиков и диаграмм без написания специального программного обеспечения.

    Документ Excel называют рабочей книгой, которая состоит из листов. Их количество может быть сколько угодно большим. Кстати, таблицы в этом приложении не имеют конца и края, в буквальном смысле. Хотя разработчики утверждают, что таблица состоит из столбцов, поименованных латинским алфавитом (А–IV), и строк, нумерованных арабскими цифрами (1–65536).

    Читать еще:  Excel 2020 описание

    Изначально (мы сейчас говорим о MS Excel 2003) в рабочей области представлены 2 панели инструментов: «Стандартная» и «Форматирование». Конечно, пользователь может добавить и другие команды, которые он использует чаще всего. Так, можно организовать панель, из которой будет вызываться функция «ЕСЛИ» посредством диалогового окна.

    Адрес ячейки формируется из буквы латинского алфавита и арабской цифры: А10, D15, T1523. В клетку можно вводить как данные, так и формулы. Если в ячейке происходит расчет, то итог будет отображен именно в ней, а заданная формула в соответствующей строке вверху.

    Разновидности функций

    В пакетном приложении Excel имеется порядка 400 функций. Их разделили на соответствующие категории (указаны несколько примеров для ознакомления):

    • финансовые: ПРОЦПЛАТ, ПУО, ПС, СТАВКА, ЧПС и т.д.;
    • даты и времени – ВРЕМЯ, ДЕНЬНЕД, ГОД и т.д.;
    • математические – ABS, ATAN, LOG, LN, SIN и т.д.;
    • статистические – ДИСП, ГИПЕРГЕОМЕТ, КВАРТИЛЬ и т.д.;
    • ссылок и массивов – АДРЕС, ВЫБОР, ОБЛАСТИ, ПОИСКПОЗ, ЧСТРОК и т.д.;
    • баз данных – БДДИСП, БСЧЁТА, БДСУММ, ДСРЗНАЧ и т.д.;
    • текстовые – ЗАМЕНИТЬ, НАЙТИ, ПОВТОР, ПОДСТАВИТЬ, ФИКСИРОВАННЫЙ и т.д.;
    • логические – ЕСЛИ, ИСТИНА, НЕ, ЛОЖЬ и т.д.;
    • проверки свойств и значений – ЕОШИБКА, ИНФОРМ, ЕЧИСЛО, ЯЧЕЙКА и т.д.

    Как видно, функция «ЕСЛИ» входит в категорию логических функций. Их более детальное изучение пройдет немного позже.

    Подробнее о логических функциях

    Формулы из данной категории необходимы для сравнения любых типов данных, а именно математических, текстовых, логических. В любой записи условий должен содержаться, как минимум, один знак сравнения: =, >, =, . Именно эти символы определяют отношение между элементами.

    Результатом заданного логического уравнения может быть ИСТИНА или ЛОЖЬ. Первый параметр выражается как (1), второй – как (0).

    Чаще всего функция «ЕСЛИ» в Excel работает в паре с такими формулами, как «И» и «ИЛИ». Первая используется для проверки нескольких условий и их одновременного выполнения. Если хотя бы один из параметров будет ложным, тогда и все условие «И» будет принимать значение (0). «ИЛИ» принимает истину, когда хотя бы одно из условий таковым является.

    «И», «ИЛИ» могут насчитывать в своей формуле до 30 условий. Однако необходимо помнить: длинные, тяжелые формулы очень трудно воспринимаются. Поэтому по возможности желательно их несколько облегчить за счет добавления столбцов или строк.

    Формула «ЕСЛИ». Тонкости ввода нескольких условий

    Функция «ЕСЛИ» выражена посредством следующей формулы, которую можно задать двумя способами.

    Первый способ: функция «ЕСЛИ» (формула может быть введена строчными или заглавными буквами) пишется вручную пользователем, скобка открывается, и табличный процессор выводит подсказку, по которой можно ориентироваться.

    Если условие истинно, тогда выполняется первое указанное выражение; если же ложно – тогда результатом станет второй параметр.

    Начинающим пользователям необходимо помнить, что табличный процессор поможет в случае наличия ошибки. Выйдет диалоговое окно, предлагающее варианты недочетов. Пользователь может самостоятельно исправить ошибку или воспользоваться справкой, где указаны распространенные примеры записи подобных формул. Любая мелочь может вызвать сбой в решении задачи. Не там стоит запятая, вместо двоеточия поставили точку с запятой, скобку не закрыли, поставили лишний знак «минус» – это далеко не полный перечень недочетов, встречающихся в работе.

    Типичные ошибки при вводе формул

    При вводе различных формул в ячейку (функция «ЕСЛИ» в Excel не исключение) могут появиться различные ошибки.

    • #ИМЯ? – неверно введен адрес ячейки, на которую ссылается функция, либо имеется недочет в имени формулы.
    • #ДЕЛ/0! – все из математики знают, что на «0» (ноль) делить нельзя. Эта ошибка напоминает об этом важном моменте.
    • #ЧИСЛО! – в различных математических функциях имеется ряд ограничений, т.е. условий (отрицательное число под знаком корня или натурального логарифма). Нужно пересмотреть заданную функцию и исправить недочет.
    • #ЗНАЧ! – возможно, пользователь ввел неверные параметры. К примеру, вместо диапазона клеток указаны ячейки методом перечисления.
    • #ССЫЛКА! – функция не может сослаться на клетку, поскольку ее адрес неверен.
    • ########## – это говорит о том, что результат вычислений не вмещается в заданной ширине столбца. Достаточно расширить его, и тогда ответ будет виден.

    Несколько примеров

    Пример функции «ЕСЛИ» может содержать одно или несколько условий. Сюда могут включаться дополнительные формулы: «И», «ИЛИ», «ЕСЛИ» и т.д.

    Задача

    Дан перечень работников, у которых имеются кредиты потребительские и жилищные. В таблице указаны начисления по заработным платам и удержания.

    • Удержать тем работникам 20%, у которых имеется два вида кредита.

    • Удержать в счет погашения задолженности 10% у тех работников, у которых имеется хотя бы один кредит.

    • Удержать 20% с тех работников, у кого имеется два кредита, в противном случае если имеется хотя бы один долг, то удержать 10% от заработной платы; если задолженностей нет, вывести строку «Без кредита».
    Ссылка на основную публикацию
    ВсеИнструменты
    Adblock
    detector